Adjunta el listado de programación del Router para que asigne DHCP de forma automática de un máximo de 20 Host en cada uno de los Switch, reservando la puerta de enlace predeterminada en el último Host de la Red a la que pertenece, cada Switch asigna direcciones IP de una Red en Clase C distinta.

Listado de programación del Router

enable =>Habilita el Router

configure terminal => Vamos a entrar a configurar el Router

interface fa0/0 => Selecciona el primer puerto fastethernet del Router

ip address 192.168.0.254 255.255.255.0 => Puerta de enlace y máscara de subred predeterminada para el puerto anteriormente seleccionado

no shutdown => Enciende el puerto “alimentación eléctrica”

exit =>Salir

 

interface fa0/1 => Selecciona el segundor puerto fastethernet del Router

ip address 192.168.1.254 255.255.255.0 => Puerta de enlace y máscara de subred predeterminada para el puerto anteriormente seleccionado

no shutdown => Enciende el puerto “alimentación eléctrica”

exit =>Salir

 

interface fa0/2 => Selecciona el tercer puerto fastethernet del Router

ip address 192.168.2.254 255.255.255.0 => Puerta de enlace y máscara de subred predeterminada para el puerto anteriormente seleccionado

no shutdown => Enciende el puerto “alimentación eléctrica”

exit =>Salir

 

ip dhcp pool switch1 => Crea un servidor dhcp llamado “switch1” e introdúcete en su configuración

network 192.168.0.0 255.255.255.0 => Nombre de Red y Máscara de Subred para las direcciones IP a asignar en este caso podré asignar como máximo 254 direcciones IP de la 192.168.0.1 a la 192.168.0.254

default-router 192.168.0.254 => Reserva esta dirección para la puerta de enlace predeterminada, es decir, la dirección IP del Router

ip dhcp excluded-address 192.168.0.1 192.168.0.234 => Excluye las direcciones incluidas en este rango

 

ip dhcp pool switch2 => Crea un servidor dhcp llamado “switch2” e introdúcete en su configuración

network 192.168.1.0 255.255.255.0 => Nombre de Red y Máscara de Subred para las direcciones IP a asignar en este caso podré asignar como máximo 254 direcciones IP de la 192.168.1.1 a la 192.168.1.254

default-router 192.168.1.254 => Reserva esta dirección para la puerta de enlace predeterminada, es decir, la dirección IP del Router

ip dhcp excluded-address 192.168.1.1 192.168.1.234=> Excluye las direcciones incluidas en este rango

 

ip dhcp pool switch3 => Crea un servidor dhcp llamado “switch3” e introdúcete en su configuración

network 192.168.2.0 255.255.255.0 => Nombre de Red y Máscara de Subred para las direcciones IP a asignar en este caso podré asignar como máximo 254 direcciones IP de la 192.168.2.1 a la 192.168.2.254

default-router 192.168.2.254 => Reserva esta dirección para la puerta de enlace predeterminada, es decir, la dirección IP del Router

ip dhcp excluded-address 192.168.2.1 192.168.2.234=> Excluye las direcciones incluidas en este rango

 

exit => Salir

end => Salir de este bloque de programación

wr =>Grabar los cambios en la memoria del router

 

enable =>Habilita el Router

configure terminal => Vamos a entrar a configurar el Router

interface fa0/0 => Selecciona el primer puerto fastethernet del Router

ip address 192.168.0.254 255.255.255.0 => Puerta de enlace y máscara de subred predeterminada para el puerto anteriormente seleccionado

no shutdown => Enciende el puerto “alimentación eléctrica”

exit =>Salir

ip dhcp pool 1STI => Crea un servidor dhcp llamado “1STI” e introdúcete en su configuración

network 192.168.0.0 255.255.255.0 => Nombre de Red y Máscara de Subred para las direcciones IP a asignar en este caso podré asignar como máximo 254 direcciones IP de la 192.168.0.1 a la 192.168.0.254

default-router 192.168.0.254 => Reserva esta dirección para la puerta de enlace predeterminada, es decir, la dirección IP del Router

exit => Salir

end => Salir de este bloque de programación

wr =>Grabar los cambios en la memoria del router

El resultado final lo puedes ver en el siguiente videotutorial:

 

 

Error ya solucionado lo que ha pasado en clase hoy día 23 de febrero es que alimentabamos los teléfonos antes de tiempo, así que siguiendo el siguiente listado debe de funcionar correctamente, disculpad y nos vemos en clase

En primer lugar selecciona el Router 2811 y el Switch 2950-24

SWITCH

enable     => Habilita el Switch
vlan database    => editar la base de datos de las Vlan del Switch
vlan 2 name 1STI     => no grabar la vlan 1 esta es la que tiene por defecto el Switch, en este caso creamos la vlan 2 con nombre 1STI
exit    => salir

configure terminal     => vamos a entrar a configurar los puertos del Switch
interface range fastEthernet 0/2-5   => Selecciona el rango del puerto 2 al 5 del Switch
switchport voice vlan 2       => Configura los puertos seleccionados en el comando anterior como VOIP
interface fa 0/1     => Selecciona el puerto 1 
switchport mode trunk    => Selecciona el puerto anteriormente seleccionado como troncal SIP
end      => Salir

wr     => Grabar los cambios en la memoria del switch

ROUTER

enable    => Habilita el acceso al router
configure terminal    => entra en la parte de configuración del router
interface fastEthernet 0/0    => Selecciona el puerto fastethernet 0/0
no shutdown     => Enciende el puerto anterior
exit   => Salir de configuración del router y vuelves a tener el acceso habilitado al mismo

ip dhcp pool 1STI     => Asigna el servidor dhcp a la vlan anteriormente creada llamada 1STI
network 192.168.0.0 255.255.255.0      => Asigna el nombre de red y máscara de subred que va ha gobernar el router
default-router 192.168.0.1     => Asigna el default gateway o como comunmente se denomina “Puerta de enlace predeterminada al router”
option 150 ip 192.168.0.1     => Asigna como máximo 150 IPs a partir de la 192.168.0.1

end    => Salir 


configure terminal   => Entra en la configuración del router
interface fastEthernet 0/0.2    => Entra en la configuración del interfaz ethernet 0/0 
encapsulation dot1Q 2    => Procede al encapsulamiento de diferentes vlan en un mismo cable ojo en este caso el 2 indica la “vlan 2”
ip add 192.168.0.1 255.255.255.0   => Dirección del default gateway y máscara de subred por defecto a encapsular 
end     => Salir
wr     => Grabar los cambios en la memoria del router

configure terminal    => Entra en la configuración del router
telephony-service    => Entra en la configuración de VOIP del router
max-dn 4   => Número de memorias reservadas “Teléfonos IP”
max-ephones 4    => Número máximo de dispositivos “Teléfonos IP”
ip source-address 192.168.0.1 port 2000    => Este es el puerto con el que salgo con las llamadas y cuál es la IP de la troncal de telefonía
auto assign 1 to 4     => Asigna las 4 direcciones IPs de forma automática

end    => Salir de este bloque de programación

wr    => Grabar los cambios en la memoria del router

configure terminal     => entra en la parte de configuración del router
ephone-dn 1   => Selecciona el Teléfono IP – 01
number 501    => Asigna el número 501 al Teléfono IP seleccionado anteriormente
ephone-dn 2   => Selecciona el Teléfono IP – 02
number 502    => Asigna el número 502 al Teléfono IP seleccionado anteriormente
ephone-dn 3   => Selecciona el Teléfono IP – 03
number 503    => Asigna el número 503 al Teléfono IP seleccionado anteriormente
ephone-dn 4   => Selecciona el Teléfono IP – 04
number 504    => Asigna el número 504 al Teléfono IP seleccionado anteriormente

end   => Salir de este bloque de programación

wr    => Grabar los cambios en la memoria del router

Enciende los 4 Teléfonos

ya te debería funcionar, si tienes alguna duda puedes resolverlo viendo el siguiente videotutorial

Artículo índice de Redes, está en continua actualización

En este artículo voy a exponer el recorrido didáctico que deberemos de saber para afrontar con garantias el tema de Redes, todos sabemos que es un tema muy amplio pero a la vez muy apasionante, se dividirá por niveles, es decir los 5 niveles de las cualificaciones profesionales.

Nivel 1

El nivel 1 estará compuesto en primer lugar por una introducción a lo que es el cableado de las Redes, empieza por leer el siguiente artículo

En segundo lugar revisa la siguiente presentación de diapositivas Presentación Redes nº 01 – Conexión de Cableado.pdf

Ahora descárgate la siguiente presenteación de diapositivas y no pases de documento hasta que no lo hayas entendido perfectamente Presentación Redes nº 02 – Introducción al direccionamiento IP.pdf, no pases al siguiente documento hasta que comprendas los términos, octeto, dirección IP, máscara de subred y nombre de red.

Para seguir más adelante deberás de saber como modificar la dirección IP y la Máscara de Subred en los equipos para ello te he preparado la siguiente presentación de diapositivas Presentación Redes nº 03 – Modificación de IP y Máscara de Subred en PC .pdf, antes de pasar al siguiente punto sería conveniente que practiques los comandos en tu propio PC

Simulación de Red nº 01

Ahora es el momento de introducirnos en el mundo de la simulación de las Redes de manos del maravilloso software de simulación de Cisco, Paket Tracer, para ello te proponemos un primer ejercicio que trata de conectar 2 Host mediante un cable de pares trenzados, para esta instalación sólo necesito dos Ordenadores con tarjeta de red y un cable paralelo o de cruce RJ45, en el dibujo de más abajo tienes un esquema de lo que se pretende montar y en el vídeo puedes ver la solución.

Red – 01 => Conexión de 2 Host mediante un cable fastEthernet cruzado

Simulación de Red nº 02

En este caso utilizamos un concentrador, comúnmente denominado Switch para conectar 2 Host a una misma Red

Red – 02 => Configuración de una Red de 2 Host mediante un Switch

 

Simulación de Red nº 03

Hacemos lo mismo que en la instalación anterior pero con 4 Host

Red – 03 => Conexión de 4 Host en 1 Red a través de un Switch

 

 

 

Nivel 2

Ahora deberemos de aprender a organizar nuestras redes para ello hay hacer una tabla de subneteo, descárgate este documento y visualiza las clases online con varios ejemplos sobre como subnetear una red

Simulación de Red nº 04

División de la instalación anterior es 2 Subredes

Red – 04 => Conexión de 4 Host en 2 Subredes

Simulación Ejercicio nº 01

A continuación lo que queremos es conectar las dos Subredes anteriores a Internet, para ello tendremos que disponer un Router, que el elemento de una instalación de redes que comunica una red privada con una red pública como podemos ver en la figura de más abajo:

En el router deberemos de configurar cual es la dirección ip de la red privada que se denomina “puerta de enlace” y cual es la dirección que el router va a utilizar para conectarse a internet que se denomina “IP pública” y que forzosamente nos la tiene que facilitar nuestro proveedor de Internet o comúnmente denominado en inglés por sus iniciales ISP, Internet Service Provider, en el siguiente video podéis ver un ejemplo de como se haría la simulación de lo que estamos hablando

 

 

En este subapartado iremos añadiendo expresiones y pasos que se tienen que cumplir siempre en el direccionamiento IP a modo de Resumen:

1º.- Nunca tendremos dentro de nuestra Red Privada 2 Host con el mismo Nombre Equipo, no funcionaría y nos daria un error con la etiqueta “Nombre duplicado de red”

2º.- Nunca podemos tener dentro de nuestra Red Privada 2 Host con el mismo Número IP, la red no funcionaría, tampoco podemos tener un Host y la puerta de enlace de nuestro Router con la misma dirección IP, a todos los efectos en este caso la puerta de enlace de nuestro Router tendría la consideración de un Host más.

3º.- Dos Host van ha estar dentro de la misma Red o Subred si y sólo sí al hacer la operación AND entre la Dirección IP de cada Host y la Máscara de Subred obtenemos el mismo Nombre de Red

4º.- Un equipo de una Red o Subred tendrá acceso a internet si y solo si tiene asignado como puerta de enlace predeterminada la dirección de la Red Privada del Router y esta dirección se encuentra dentro del rango de host de la Red o Subred en la que se encuentra la dirección IP de nuestro equipo

¿Como abordar problemas de Redes?:

Tenemos dos casos:

Caso A:

Construcción de una red desde cero:

En este caso deberemos de de seguir los siguientes pasos:

1º.- Identificar las diferentes redes o subredes que quiero construir acorde a las necesidades del cliente:

2º- Recomendar instalar un concentrador o switch en cada clase, aula, taller, etc con la capacidad suficiente de dar servicio a todos los puestos de trabajo de la sala mayorados en un 20%

3º- Intentar subnetear siempre que sea posible y ajustar el subneteo de tal forma que las distintas subredes queden lo más ajustado posible si es necesario aplicar el subneteo VLSM

4º- Asignar un nombre de PC a cada puesto de trabajo correlativo y que sea fácilmente identificable, por ejemplo Taller01 , Aula_01_Phone_01, etc…

5º- Crear los grupos de trabajo acorde a las necesidades del propietario

6º- Asignar las direcciones IP por orden de tal forma que si estamos en una industria con distintos talleres, en el taller 1 asignaremos al primer equipo la primera dirección del rango privado de IPs dependiendo de la clase a la que pertenezca los equipos de la Red que quiero construir, así por ejemplo si vamos a montar una Red en clase C la dirección IP del primer equipo será 192.168.0.1, recordad que para cada clase de direcciones IP existe un rango determinado de direcciones que puedo usar para uso privado

7º- Asignar la Máscara de Subred a cada equipo teniendo en cuenta que deberemos de subnetar siempre que sea necesario y ajustar los subneteos para ocupar las mínimas porciones de Red posibles, recordad que la Máscara de Subred por defecto implica que ese equipo pertenece a una Red y que si está subneteada la Másca de Subred el equipo pertenecerá a una Subred

Caso B:

Revisión de una instalación ya existente

1º.- Revisar que no exista en mi Red Privada ningún nombre de equipo que sea igual, si esto ocurre me dará un error de nombre de equipo duplicado en la red y esta no funcionará

2º.- Revisar que los grupos de trabajo sean los mismos para los equipos que queremos que se vean en la misma red de Windows

3º.- Revisar que no se repita dos equipos con la misma dirección IP

4º.- Realizar la operación AND entre la dirección IP y la Máscara de Subred de cada equipo y obtener el Nombre de Red, recordad que todos los equipos que tengan el mismo nombre de Red pertenecerán a la misma Red o Subred

5º.- Revisar el Subneteo y ajustar el mismo para que nos sobren el mínimo de direcciones IP libres de los Host que compone dicha Subred