Telefonía

Error ya solucionado lo que ha pasado en clase hoy día 23 de febrero es que alimentabamos los teléfonos antes de tiempo, así que siguiendo el siguiente listado debe de funcionar correctamente, disculpad y nos vemos en clase

En primer lugar selecciona el Router 2811 y el Switch 2950-24

SWITCH

enable     => Habilita el Switch
vlan database    => editar la base de datos de las Vlan del Switch
vlan 2 name 1STI     => no grabar la vlan 1 esta es la que tiene por defecto el Switch, en este caso creamos la vlan 2 con nombre 1STI
exit    => salir

configure terminal     => vamos a entrar a configurar los puertos del Switch
interface range fastEthernet 0/2-5   => Selecciona el rango del puerto 2 al 5 del Switch
switchport voice vlan 2       => Configura los puertos seleccionados en el comando anterior como VOIP
interface fa 0/1     => Selecciona el puerto 1 
switchport mode trunk    => Selecciona el puerto anteriormente seleccionado como troncal SIP
end      => Salir

wr     => Grabar los cambios en la memoria del switch

ROUTER

enable    => Habilita el acceso al router
configure terminal    => entra en la parte de configuración del router
interface fastEthernet 0/0    => Selecciona el puerto fastethernet 0/0
no shutdown     => Enciende el puerto anterior
exit   => Salir de configuración del router y vuelves a tener el acceso habilitado al mismo

ip dhcp pool 1STI     => Asigna el servidor dhcp a la vlan anteriormente creada llamada 1STI
network 192.168.0.0 255.255.255.0      => Asigna el nombre de red y máscara de subred que va ha gobernar el router
default-router 192.168.0.1     => Asigna el default gateway o como comunmente se denomina “Puerta de enlace predeterminada al router”
option 150 ip 192.168.0.1     => Asigna como máximo 150 IPs a partir de la 192.168.0.1

end    => Salir 


configure terminal   => Entra en la configuración del router
interface fastEthernet 0/0.2    => Entra en la configuración del interfaz ethernet 0/0 
encapsulation dot1Q 2    => Procede al encapsulamiento de diferentes vlan en un mismo cable ojo en este caso el 2 indica la “vlan 2”
ip add 192.168.0.1 255.255.255.0   => Dirección del default gateway y máscara de subred por defecto a encapsular 
end     => Salir
wr     => Grabar los cambios en la memoria del router

configure terminal    => Entra en la configuración del router
telephony-service    => Entra en la configuración de VOIP del router
max-dn 4   => Número de memorias reservadas “Teléfonos IP”
max-ephones 4    => Número máximo de dispositivos “Teléfonos IP”
ip source-address 192.168.0.1 port 2000    => Este es el puerto con el que salgo con las llamadas y cuál es la IP de la troncal de telefonía
auto assign 1 to 4     => Asigna las 4 direcciones IPs de forma automática

end    => Salir de este bloque de programación

wr    => Grabar los cambios en la memoria del router

configure terminal     => entra en la parte de configuración del router
ephone-dn 1   => Selecciona el Teléfono IP – 01
number 501    => Asigna el número 501 al Teléfono IP seleccionado anteriormente
ephone-dn 2   => Selecciona el Teléfono IP – 02
number 502    => Asigna el número 502 al Teléfono IP seleccionado anteriormente
ephone-dn 3   => Selecciona el Teléfono IP – 03
number 503    => Asigna el número 503 al Teléfono IP seleccionado anteriormente
ephone-dn 4   => Selecciona el Teléfono IP – 04
number 504    => Asigna el número 504 al Teléfono IP seleccionado anteriormente

end   => Salir de este bloque de programación

wr    => Grabar los cambios en la memoria del router

Enciende los 4 Teléfonos

ya te debería funcionar, si tienes alguna duda puedes resolverlo viendo el siguiente videotutorial

Se trata de trabajar con los troncales de Asterisk

A partir del Asterisk que tenéis en vuestro grupo de prácticas realizar los siguientes puntos:

1º.- Da de alta los siguientes números de abonado en tu centralita Asterisk

       – Jazztel – 953 50 50 50 (prefijo “1”)  secret : “profesor1234”

       – Vodafone – 953 50 50 51 (prefijo “2”) secret : “profesor1234”

       – Movistar – 953 50 50 52 (prefijo “3”) secret : “profesor1234”

Adjuntar pantallazo de la página principal donde se ve los 3 Toncales “Trunk SIP” dados de alta

2º.- Desarrolla las siguientes estrategias para las llamadas salientes :

      – Línea Jazztel sólo llamadas locales, provinciales y al número móvil “600 00 00”

      – Línea Vodafone sólo llamadas internas y a todos los números  que comiencen por 902, 903 y 904

      – Línea Movistar sólo llamadas a teléfonos móviles

Adjuntar pantallazo de la página principal donde se ve las 3 configuraciones de las llamadas salientes

3º.- Configura Asterisk para que reciban llamadas mediante una locución en la que podré elegir mediante el teclado con que usuario quiero conectarme, en vuestro caso los integrantes de vuestro grupo, por ejemplo, “pulsa 1 para hablar con Alfredo, 2 para contactar con Raúl, etc… “

4º.- Una vez concluidos los pasos anteriores avisad al profesor para verificar su correcto funcionamiento

Se trata de instalar la siguiente instalación de telefonía basada en VOIP:

Instala Elastix y Jitsi en un puesto de trabajo fijo y conecta mediante WIFI con Smartphone a los demás componentes de tu grupo de prácticas y al Profesor con una extensión, “4000”,y una secret “profesor1234”, a continuación realiza las siguientes actividades

1º.- Haz dos grupos de timbrado uno con 2 móviles más el puesto fijo y otro con tres móviles

2º.- Crea una sala de conferencias en la que se puedan incluir todos los componentes del grupo, comprueba que funciona

3º.- Crea otra sala de conferencias restringida para tres extensiones móviles, uno de ellos será el del Profesor, e incluye un mensaje de bienvenida indicando el motivo de la conferencia, por ejemplo, “estás entrando en una reunión sobre posibles estrategias de marketing de nuestra empresa”, si esto no es posible incluye un trozo de una canción a algún audio que te descargues de internet.

4º.-Realiza al menos 5 llamadas entre las distintas extensiones incluida la conferencia

5º.- Envíame un listado con toda la actividad de tu Elastix en formato PDF, adjunto a esta actividad

6º.- Haz una backup de tu Elastix en este punto y la instalas en otro equipo fijo distinto, comprobando el profesor que esta correcto la reinstalación